WordPress.org

Español

Ready to get started?Download WordPress

[resolved] [cerrado] Mi sitio de WordPress no me envia correos .. (23 posts)

  1. Juan Campos
    Miembro
    Publicado hace 3 years #

    Hola en mi sitio no consigo recibir correos.

    Me explico ,
    1º.- Cuando te logueas y pides una nueva clave , te pide el email pero no envia la nueva clave

    2º.- Cuando relleno el formulario de la pagina "Contacta" tampoco envía información alguna.

    No se si es que hay algo que no he configurado... , o que pueda pasar.

    Alguna pista

    Gracias

    Juan desde Asturias

  2. lonchbox
    Moderador
    Publicado hace 3 years #

    Has verificado la carpeta de spam?, por lo general para ahí ;)

  3. Juan Campos
    Miembro
    Publicado hace 3 years #

    Si he mirado en "todos" los sitios. Y no recibo.

    Puede ser un problema del servicio de hosting ?

    Gracias

    Juan

  4. pedrocarrillo
    Moderador
    Publicado hace 3 years #

    en el wp_config.php puedes configurar la depuración de la sigueinte manera:

    define('WP_DEBUG', true);

    Así tendrás el informe de error de tu caso concreto. Si sigues con problemas, copia el mensaje de error que veas al enviar correo.

    P.D: No te vayas a asustar de los mensajes y advertencias que no sean críticos ;-)

  5. Juan Campos
    Miembro
    Publicado hace 3 years #

    En este grafico se puede ver lo que obtengo al pedir una nueva contraseña.

    Gracias por tu atención

    Juan desde Asturias

  6. pedrocarrillo
    Moderador
    Publicado hace 3 years #

    Esas son las advertencias de las que te dije que no te preocuparas. No son errores son notificaciones.

    Incluye información de tu hosting: sistema operativo, servidor, etc

  7. Juan Campos
    Miembro
    Publicado hace 3 years #

    Mi hosting es HOSTALIA

    Tengo un plan "avanzado linux"

    WordPress corre en una maquina linux bajo apache ...

    No se si es esto todo lo que preguntas...

    Gracias

    Juan

  8. Mariano Perez
    Moderador
    Publicado hace 3 years #

    Puede ser que el servidor Apache no tenga configurado el módulo smtp para mandar correos con él. Confírmalo con Hostalia.

  9. Juan Campos
    Miembro
    Publicado hace 3 years #

    La respuesta de Hostalia

    Nuestro servidor apache esta configurado para que mande correos, pero deben realizarse bien con un smtp autenticado o por programacion usando un from valido especificado con la función -f. Desconozco el funcionamiento del WP. No se si esta informacion podra servirle de algo.

    Gracias

    Juan

  10. Mariano Perez
    Moderador
    Publicado hace 3 years #

    Entonces descartado ese extremo, debería funcionar. Conéctate a la base de datos (con los datos que están en el archivo config.php) y verifica que en la tabla de usuarios el dato de tu email está bien puesto.

  11. Juan Campos
    Miembro
    Publicado hace 3 years #

    Conéctate a la base de datos (con los datos que están en el archivo config.php) y verifica que en la tabla de usuarios el dato de tu email está bien puesto.

    Puedes aclararme un poco el procedimiento

    Gracias

    Juan desde Asturias

  12. Juan Campos
    Miembro
    Publicado hace 3 years #

    En la tabla figura correctamente el email del admin (yo)

  13. Mariano Perez
    Moderador
    Publicado hace 3 years #

    En ese caso comprueba que el servicio smtp funciona correctamente así: http://rm-rf.es/comproba-funcionamiento-correo-smtp-via-telnet/

  14. Juan Campos
    Miembro
    Publicado hace 3 years #

    He seguido lla pagina...

    juan@juan-desktop:~$ telnet x.x.x.x. 25 ( smtp de mi dominio)
    Trying x.x.x.x...
    Connected to x.x.x.x.
    Escape character is '^]'.
    220 relayout03-dsp.dominioabsoluto.net ESMTP
    helo juam-desktop
    250 relayout03-dsp.xxxxxxxxxxx.net
    mail from:vcm@vamosacambiarelmundo.org
    250 2.1.0 Ok
    rcpt to:jcampos@vamosacambiarelmundo.org
    554 5.7.1 <jcampos@vamosacambiarelmundo.org>: Relay access denied

    **********************************

    Entiendo que aun logueando correctamente no me deja enviar ?

    Gracias por tu atención

  15. Rafa Poveda
    Administrador
    Publicado hace 3 years #

    ¿Tu servidor necesita autentificación PHP para utlizar el SMTP?

  16. Mariano Perez
    Moderador
    Publicado hace 2 years #

    Como dice Raven, simplemente tienes que autentificar el envío de correo.

  17. Juan Campos
    Miembro
    Publicado hace 2 years #

    Como dice Raven, simplemente tienes que autentificar el envío de correo.

    Disculpa mi ignorancia.

    Me puedes indicar que y como he de hacer para que me funcione

    Un saludo

    Juan desde Asturias

  18. Juan Campos
    Miembro
    Publicado hace 2 years #

    ¿Tu servidor necesita autentificación PHP para utlizar el SMTP?

    Te refieres a esta respuesta que me da Hostalia

    Nuestro servidor apache esta configurado para que mande correos, pero deben realizarse bien con un smtp autenticado o por programacion usando un from valido especificado con la función -f.

    Y ahora ¿ como hago para que me funcione ?

    Gracias

    Juan desde Asturias

  19. Rafa Poveda
    Administrador
    Publicado hace 2 years #

    Esto quiere decir que puedes utilizar alguna de estas opciones:

    • Que para enviar correos antes tienes que recibir alguno (y así el sistema sabe que eres tú). Eso es lo que se utiliza a la hora de entrar en algún sistema de correo.
    • Que tienes que utilizar usuario y contraseña a la hora de enviar correos.
    • Que tienes que forzar el envío añadiendo un -f a la función de envío.

    La forma más sencilla es utilizar un plugin que te ayude a la autentificación. Aquí tienes dos que te pueden servir:

    http://wordpress.org/extend/plugins/wp-mail-smtp/
    http://wordpress.org/extend/plugins/configure-smtp/

    Espero que te sirvan.

  20. Juan Campos
    Miembro
    Publicado hace 2 years #

    Esta SOLUCIONADO.

    Gracias a todas las personas que habéis puesto vuestro grano de arena.

    Gracias a Rafael Poveda por poner la puntilla a mi problema.

    Ya recibo los corros para modificar el pass

    Un cordial saludo

    Juan desde Asturias

  21. Juan Campos
    Miembro
    Publicado hace 2 years #

    Me olvide de indicar que la SOLUCIÓN pasa por usar el plugin http://wordpress.org/extend/plugins/wp-mail-smtp/

    Gracias

    Juan

  22. Rafa Poveda
    Administrador
    Publicado hace 2 years #

    Añado que hay algunos hosting con los que nos estamos encontrando este problema últimamente.

  23. guadaacoge
    Miembro
    Publicado hace 2 years #

    Hola a todos!! Soy nuevo en esto, espero escribir en el lugar correcto de acuerdo a las normas.

    Escribo aquí porque estoy teniendo un problema bastante asqueroso con la página web que estoy haciendo con WordPress y consultar para ver si me puedes echar una mano.

    Te describo un poco el problema:

    Lo que está fallando en mi WordPress es que no recibo ningún mail. Por ejemplo cuando un usuario quiere hacer un comentario debería llegarme un mail para moderarlo pero no llega nada. Sin embargo, en el panel de administración de WordPress, en el apartado de comentarios, sí que está el mensaje pendiente de moderar.
    Además, otro ejemplo, cuando no recuerdas la contraseña para logarte en el blog y pinchas en el típico enlace "no recuerdo mi contraseña" para que te la manden por mail no me llega nada y el navegador me da un mensaje que dice "HTTP 500 Error interno del servidor".

    Yo tengo hosting con DinaHosting, mi dominio es http://www.guada-acoge.org/ y la dirección de correo que tengo asociada es del mismo dominio: guada-acoge@guada-acoge.org

    Además he estado intentando instalar un plugin que supuestamente me solucionaba todos estos problemas llamado "wp mail smtp" pero no consigo hacerlo funcionar. Lo instalo y lo activo correctamente pero cuando intento acceder al setting de este plugin se queda en blanco la página sin mostrar nada.

    He probado con otro plugin parecido llamado "configure smtp" y aunque puedo acceder al setting cuando voy a mandar un mail de prueba para ver si funciona se queda todo en blanco otra vez.

    También probé en lugar de tener un mail del mismo dominio con un mail de gmail pero los problemas seguían siendo exactamente los mismos.

    Además también he modificado los permisos de todos los archivos y carpetas del blog: archivos--> 644; carpetas -->755

    He consultado en los foros de WordPress y me han dicho que el problema debe estar en el hosting, pero he consultado con el hosting y no me han sabido decir nada.

    ESTOY DESESPERADO!!!!! No se que más probar ni donde seguir mirando posibles causas del error y si pudieras darme algún consejo te estaría eternamente agradecido.

Tema Cerrado

Este hilo se ha cerrado para nuevas respuestas.

About this Topic

Tags